So disappointed in UFO Stretch

After reading so many users here sing it praises, I bought a UFO Stretch License. Works very nice for upright (roman) data, but it seems incapable of recognizing any Italic data I have. The website has little in the say of contact info or help, so save your money, A not ready for prime time tool.


  • I haven't used it for a while, but I don't remember having a problem with italics.
    Maybe drop @typemytype a line?

  • I've mostly used in on uprights, but did use it on an italic project a few months ago. The results were a bit less good than the roman, but I was only using UFOstretch to rough in proportions for a display version. That's how I mostly have used the tool, as a way to get a reasonably clean scaled and interpolated rough with independent X and Y control (the latter being the big benefit over RMX Scaler).

    The problem I regularly have with UFOstretch is that the UI seems to have a problem with fonts with a >1000 unit em.
  • MY problem is that it will not even recognize Italic Font data. Nothing populates the interface when selecting Italic data.
  • MY problem is that it will not even recognize Italic Font data. Nothing populates the interface when selecting Italic data.
    I wouldn't know what causes that. I think if it worked with your ufo's containing romans, it should not be any different with ufo's containing italics.
  • >>if it worked with your ufo's containing romans, it should not be any different with ufo's containing italics.<<

    You would think so, but that is not the case.

  • Do your italics lack points at the x-extrema? Anything else other than having an italic angle entry that might differentiate the italic, at a technical level?
    (Just wondering what might trigger the problem.)
  • I remember having a problem a while back with UFO's exported by Glyphs showing up 'empty' in Superpolator. Adding a custom property entry in the master fixed this. (can't remember what the entry was though.) 

    Is there any difference between how you created the ufo's for roman and italic?
  • I export to UFO via FontLab 6. Points are on all extrema. No Italic data shows up in the interface. I've tried it with several sets of data. Roman fine. No Italic.
  • Might it be better to submit a bug report and try figure out what exactly makes this fail rather than publicly sharing your contempt for the app altogether?
  • I've never had a problem with italic data working any differently than roman. The biggest problem with UFO Stretch is the lag it can really slow to a crawl depending on what you're doing.
  • Did you confirm that the italic data out of FL VI is properly conformed? Seems unlikely, but possible, that something about what was written by FL got translated idiosyncratically. 
  • Best results with FL5 + UFOcentral. I never had a problem with italics.
  • This might be related - maybe not.
    (Because maybe UFOStretch uses similar Python Libraries or pens etc.):

    I had problems when using Italic shapes (of serif font) with Mutator Scale.
    MutatorScale uses/needs reference Glyphs for measuring stroke weights.
    (also glyph "H" for example)

    So in my case it helped to remove the overlaps of glyph H.
    (when constructed out of 3 shapes for examples: a horizontal Stroke and two vertical strokes)

    Maybe this helps with UFOStretch as well.
  • No overlaps present in the Italic data.

  • Michael JarboeMichael Jarboe Posts: 258
    edited September 2018
    Could you try creating a new italic file that is stripped down to just a particular amount of glyphs and data? I suggest that because back in the day I'd occassionally have problems in FontLab, so I'd start a new file and systematically transfer the glyphs and data to the new file until I reached a point in which the problem was reproduced, and I could then identify or address it, or at times I believe it went away entirely. On further thought, I faintly recall having corruption-like issues in with files due to random (near invisible) floating points, that I'm usually very careful to avoid.

    Lately I have the feeling that some of these software issues are idiosyncratic amongst us. For example, with Robofont whenever I edit Font Info it leads to the app crashing and it is a consistent and reproducible problem (imagine the joy of editing Font Info across a 20 style font family!). I submitted a bug and then replied to a request to submit a log file and never received an answer. I can only imagine if this was a consistent problem among other users it either would've been resolved by now or no one would use the application.
  • Thanks for all the suggestions, but  . . .  I've found another solution and trashed my copy of UFO Stretch. 
  • What's you other solution? Always interested to know about other ways of doing things.
  • It works fine for me.
  • Since I use FontForge on Windows (and not directly with UFO data), I coded up my own version of this functionality, which *does* account for the italic data. It can be run via command line or as part of a library, but I haven’t gotten around to creating a GUI for it.
  • Maybe drop @typemytype a line?

    So was @typemytype able to help you, @James%20Montalbano?
  • I went back to FL5 and used RMX tools.
  • RMX tools don't enable independent x and y interpolation, right?
Sign In or Register to comment.