Webfont embedding problem with basic latin

edited October 1 in Type Business
Hello everyone,

via Typekit (Adobe) I have implemented the lovely fonts of OHNO (Swear Display & Text) to the project that I am working on. There are some embedding issues with the webfonts, I guess.



Typekit settings look like this:



I wanted to ask you if anyone here had the same problem with basic latin characters like q, w, x before? 

Thank you.

PS. I think I accidentally opened the discussion in the wrong category. It would be great if the admin could move the topic to the right one. Sorry.

Comments

  • Mark SimonsonMark Simonson Posts: 1,359
    Maybe you need to include English in the subsetting.
  • That actually worked Mark, thank you very much! I didn’t know that I have to select it, too. Because with the other projects I didn’t have to and it worked just as usual. 

    The only problem I had afterwards was with the A(a)circumflex. Just as you mentioned I also have included French and it worked. So maybe this topic would help Turkish designers who want to implement Swear-Text & Display webfonts (maybe some others, too) via Typekit, they have to select English, French and Turkish language subsetting at the same time. I hope that it won’t make any performance issues.



    If anyone knows a better way to implement certain glyphs via Typekit and can tell me how it can be done, I would greatly appreciate it.

    Thanks again for your help Mark.


  • Mark SimonsonMark Simonson Posts: 1,359
    You may want to contact Typekit support about this. Q, W, and X are apparently not required for Turkish, except for foreign words, so that may be why they were excluded. If that's not true for Â, maybe there is an error in the Turkish subset in Typekit.
Sign In or Register to comment.