Font naming issues - family not nesting in Illustrator

Hey guys,

looking for some advice on this one. I've been using Karsten Lucke's font naming scheme (see http://kltf.de/downloads/FontNaming-kltf.pdf). I'm still getting into trouble though. At the moment I'm not sure if this is because I'm doing something wrong in the naming scheme, or whether there is some kind of issue with my font cache?

See attachment: in Font Suite the (small) family behaves just fine, Regular and Regular Italic are nested under the family name. But when I use the font in Illustrator, two names are being composed that I have to call up separately (so Regular and Regular Italic are not nested under one family).

Any suggestions?

Comments

  • Font info screens for both files as a reference. I really hope someone can point out the (obvious??) fail here, would help a lot. I've been staring at this too long...

    image
  • Did you intend to have "Menu Name" filled out for one and not the other?
  • Hey Craig, thanks for your reply. Nope, that wasn't my intention. Doesn't explain what's going on though. Maybe I need a system reboot or something...
  • Jan Willem WennekesJan Willem Wennekes Posts: 148
    edited November 2013
    Not completely true by the way. Removing that "Menu Name" option and re-installing the new .otf files now shows the exact same result in Font Suite, but in Illustrator the italic version is gone at first view. Rebooted the system: same thing again. The menu still shows "Black Diamond Italic" as the font name and "Regular Italic" as the font style... oddness...
  • Try only "Italic" as the style name.
  • Thanks for your comment Georg. I must be misinterpreting the scheme - I thought I had "Italic" as the style name...both "Style Name" and "OT Style Name" have just that filled in - should it be somewhere else too?
  • Can you post screen shots of your 'Additional OpenType names' info as well?
  • Yes, here they are (why can't that window be any bigger?)

    image
  • Check for any stray spaces at the end of the entries. That has caught me out before.
  • James MontalbanoJames Montalbano Posts: 902
    edited November 2013
    Adding a -Regular to the PS Name and Full name can't hurt.
  • Clicking on the image 2x does make it bigger
  • Delete everything in the “additional names” sections, fill out the menu name with the family name, copy whatever you have in the “full name” section into the “FOND name” and give it a try. If it works, update the “additional names”.
  • I have never actively filled out the [name] table, and I have never had a problem with font name performance.
  • Thanks for all the comments guys! This is very helpful. BTW James: I meant the font info window in Fontlab, not the image here on the forum. So odd that you can't drag it to be any bigger even though the form is much bigger than the menu...

    - Checked for spaces (none, but good call).
    - Added -Regular to the PS name and Full name
    - deleted all additional OpenType names > I had to change the preferences to "Append OpenType name records" (I had set it to "Export only OpenType name records" because it was advised in documentation)
    - copied full name to FOND name
    - copied family name to menu name

    >>> it worked! So maybe it had something to do with the "Export only OpenType name record"? Left the "Additional OpenType names" empty for now.

    It works both in Illustrator and Word - however in Word only the italic version seems to work (even though it appears with just the family name). Maybe this is a font cache thing? Or still something wrong?
  • For what it is worth I have tested a font with the following name metadata settings, which works perfectly in both Illustrator (Mac CS6) and Word (Mac 2011).
  • Jan Willem WennekesJan Willem Wennekes Posts: 148
    edited November 2013
    Karl, thanks for this, it helps a lot to see the screens. I checked them against my settings.

    Now it's becoming interesting: how did you generate the additional opentype names? Delete them all and "import names" (the arrow)? Because in my screen it says "Black Diamond Regular" (4 3 1 1033) where you have "BlackDamon-Regular". How could that be? 6 1 0 0 and 6 3 1 1033 are the same as yours ("BlackDamon-Regular").

    Also with the Italics version, your 4 1 0 0 and 4 3 1 1033 are the same: "Black Diamond Italic" (the second one here isn't "BlackDamon-Italic" as I would expect).

    Also, I don't have entry 16 and 17

    My FOND name was "Black Damon Regular" by the way (as James Todd suggested), but I changed it to "Black Damon" to make it the same as your settings.

    Tested it: still the same effect, it works in Illustrator, not in Word (only the italics version).
    Tested it with manually added 16 and 17 in same fashion: same result.

    Gah!
  • I would recommend running Font Nuke to clean out your font caches.
    http://fontnuke.en.softonic.com/mac
  • I created new font files and added all information manually starting with the 'Names and Copyright' info, then 'OpenType-specific names' and finally generating the 'Additional OpenType names' and manually adding 16 and 17. My preference settings are:

    Preferences/Generating OpenType & TrueType - 'Export only OpenType name records...'

    Also, I generated TrueType files, not CFF.

    If I placed the word 'Damon' instead of 'Diamond' it is a typo. Hope that helps.
  • On the "OpenType-Specific font names" screen, enter the Mac name. The Mac Name has to equal the OT Family Name plus the OT Style Name exactly. So for the Regular face enter "Black Diamond Regular" and for Italic enter "Black Diamond Italic" (without the quotes of course).

    It isn't the case in this font but by "exactly" I mean if the style name has been shortened in the Basic Set Of Font Names screen to "Black It", on the OpenType-specific screen you can't have Black It as the OT Style and Black Italic in the Mac name, you have to either change the style to Black Italic or the Mac name to Black It as well.

    FontLab often won't read the Mac name back in, but it is required, especially for apps like FontExplorer.
  • Thanks everybody for helping out so much. I nuked the font cache, rebooted the system and voila! So it seems it was both a case of doing a better job at naming, and the font cache.

    Karl: Damon was my bad - I had to change the name of this typeface as there was already a Black Diamond out there (so I changed it to Black Damon).

    Why did you generate ttf files by the way? No otf files? Both are handy to have I would say...?
  • @Jan, both are indeed handy, depending on context but I tend to stick with ttf when running tests.
  • Thanks for the reply Karl, is there a specific reason to stick to the ttf's? Or just custom?

    I'm glad the typeface works as it should now btw, so thanks again!
  • In situations where I have worked with PS (Type 1 and OT) files I have often found that more work is required to get to the same place. Also, I prefer how the numbers work out in metrics for TrueType and when working with Windows, particularly for older builds, they often just work.
  • That's interesting to hear Karl, thanks for the reply.
Sign In or Register to comment.