Monotype font platform upload and update issues

Dusan JelesijevicDusan Jelesijevic Posts: 51
edited April 8 in Type Business
Hi all,

I just wanted to check if what's happening to me actually an isolated case or it happens to others as well.

Monotype font platform won't let me upload anything in existing font family – nor font files nor images.
Every time I try, messages in red rectangles in top right corner of the page jumps out with warning that something is not right.

MyFonts support doesn't respond on email (although they responded on Twitter by forwarding issue to support again) so far.

I wanted to upload new version of OTF files for our latest release that have some kerning issues that are present at MyFonts website only, while on other vendors, same font files don't have that kerning issue. So, I suspect that there's something wrong with this font platform which we have not been informed about from them.


Does anyone else have similar issues with their platform recently?


Thanks,
Dušan




Comments

  • It's been error on my side.
    My apologies to everyone I may confused.
    This topic can be removed if admin agrees.
    Sorry once again.
  • Justin PennerJustin Penner Posts: 13
    edited April 8
    I noticed recently that the MyFonts type tester adds kerning rules together if you have duplicate rules applying to the same pair. I'm not sure what the correct spec behaviour is, but all my pre-release testing on the font was done in software that seems to just pick one kerning pair instead of combining them, so I didn't catch the error until after the release, when I happened to see that kerning pair in the type tester.
  • Paul HanslowPaul Hanslow Posts: 83
    A colleague of mine recently had multiple issues with uploading images to support a new release on MyFonts. First the images wouldn't upload, then only one image would show in the carousel. It took them multiple emails and other avenues of contact to get MyFonts to look into the issue and fix it, taking about a month to do so.  I honestly don't know what's going on with MyFonts.
  • Mine problem was that I wanted to update existing OTF files with the same files (with same Md5). I was assuming that Platform badly uploaded files as some kerning pairs appeared to look very strange on their render text samples comparing to mine tests and other vendor's websites where I uploaded same font files. So, new version must be really new.

    Regarding to kerning issue... I got answer yesterday: "By default, our new font rendering service will only render kerning pairs from the standard GPOS pairing font table. If you have kerning in the 'kern' table, we recommend changing the binary to have GPOS kerning table entries that are available in the 'kern' table."
  • Thomas PhinneyThomas Phinney Posts: 2,095
    edited April 9

    Regarding to kerning issue... I got answer yesterday: "By default, our new font rendering service will only render kerning pairs from the standard GPOS pairing font table. If you have kerning in the 'kern' table, we recommend changing the binary to have GPOS kerning table entries that are available in the 'kern' table."
    I initially read this as the reverse!  :D

    Not crazy for them to expect GPOS kerning, in new fonts. But there are plenty of old fonts sold on MyFonts.

    Has there been a trend for layout engines to stop supporting the 'kern' table in favor of GPOS kerning only? If so, which ones? I had not heard this previously.
  • There is more: "Recently we upgraded our font rendering system. It's much faster, more reliable, and makes the site load much faster. Our developers have been increasing the functionality of the renderer since then.... Currently, our font renderer has the same behaviour as Word and does not render kerning if there is a default kerning table only. Our developers are actively working on upgrading this. It will be fixed automatically once the upgrade is done."
  • Adam JagoszAdam Jagosz Posts: 664
    edited April 9
    I always get errors when uploading new versions of multiple styles at once. Sometimes it will reject some of the styles with a cryptic error message and when you try to upload the files that were rejected again, it tells you "this file already exists". Sometimes the seemingly rejected files appear as new (albeit empty) styles at the bottom and I am able to remove them from there (after typing DELETE) and upload again, otherwise I need to refresh the site and start the whole edit operation from scratch.
    Might or might not have something to do with the fact I have more than one font family inside that MF product.
  • There is more: "Recently we upgraded our font rendering system. It's much faster, more reliable, and makes the site load much faster. Our developers have been increasing the functionality of the renderer since then.... Currently, our font renderer has the same behaviour as Word and does not render kerning if there is a default kerning table only. Our developers are actively working on upgrading this. It will be fixed automatically once the upgrade is done."
    "...actively working on upgrading..." LOL! I got the same response when I complained regarding a similar problem more than a year ago. They did nothing to fix the issue in the meantime. I gave up. Btw, here's the problem I complained about – mystery spacing appears in font preview (only on MyFonts):


  • Christian ThalmannChristian Thalmann Posts: 1,653
    edited April 9
    I'm also having trouble with the Monotype Font Platform. I was supposed to add some extra posters for an upcoming promo, but it wouldn't accept the edit because of some new guidelines. At that occasion, I noticed only 50 out of the 99 fonts of the family were even shown in the MFP. Trying to drag the missing OTFs in to update them, I got cryptic error messages for some of them and duplicate fonts for others. I ended up canceling the whole edit so as not to leave the family in a broken state.
    After several more attempts (including a half-hour wait for three uploaded OTFs to be «processed»), I got spontaneously kicked out of the process and was asked to log back in. After that, I was able to upload the new images and remove most of my sale packages in order to pass the new guidelines. That worked, but I'm still worried half of my fonts might go missing or be excluded from the packages because they didn't show up properly in MFP. Unfortunately, I can't make any more attempts to fix that now because my edit is in limbo and waiting 24 h to be published on MyFonts, for better or worse...
    /rant
  • Not crazy for them to expect GPOS kerning, in new fonts. But there are plenty of old fonts sold on MyFonts.
    Font ageism is in the air...
  • Dusan JelesijevicDusan Jelesijevic Posts: 51
    edited April 10
    Btw, here's the problem I complained about – mystery spacing appears in font preview (only on MyFonts):
    We have pretty similar (if not the same) problem.

    Christian Thalmann said:
    I'm also having trouble with the Monotype Font Platform. I was supposed to add some extra posters for an upcoming promo, but it wouldn't accept the edit because of some new guidelines.
    If poster dimensions are not proper (1440x720), it won't accept it. But I'm sure that's not case cause of what you said after quoted part. 

    Those errors you all mentioned – errors during uploading new font files – after being frustrated at first, I started acting like that's normal thing  :) They are present for almost the beginning of the platform, but they haven't been solved so far. They are pretty sure aware of it, but... obviously things are not working smoothly.

    I am a bit pissed on all this cause of bad renders MF give, the font I'm talking about now looks like half-product and it effects on customers choice for sure (like @Nikola Kostic probably feel with his Allotrope).
Sign In or Register to comment.