MyFonts Font Platform Name Issue

 I used the myfonts font platform for the first time today, with knot in stomach, dreading it. Of course I ran into a problem immediately. My font family has two fonts "Font Name Regular" and "Font Name Caps Regular" They show up separately in the font menu. The font platform named them both "Font Name Regular" and then gave me a warning to correct one of the names to like bold I guess. I sent an email to foundry support. While I was waiting for a response, I thought I would ask if anyone else had a similar problem?


  • Adam JagoszAdam Jagosz Posts: 664
    edited January 2020
    What is happening:
    1. Your families are "Font Name" and "Font Name Caps"
    2. The family/product name is detected as "Font Name"
    3. The styles are both Regular
    Solution: just change the style (on the platform, not necessarily in the font itself) of the second font to "Caps Regular".
  • After hearing back from the support team and giving it a second try, it worked out, although there are other problems with my font to address. The reason I was having such a hard time is because when I clicked to change the name I got no text cursor prompt but an x to delete. I just clicked it and started typing and that worked.

Sign In or Register to comment.