Is FontLab VI for real?

Adam JagoszAdam Jagosz Posts: 611
edited May 2019 in Type Design Software
So... I've been trying out the FontLab VI trial (never worked with previous versions of FontLab) and I'm wondering... is it just me, my non-SSD HDD, or is this program really wonky?
I created one issue ticket for now and maybe I'll cover the rest later too, but for now I just feel the urge to spill it here—sorry...
Starting with the autosave that spams the directory with new and new backup files and never clears them up.
Then zooming with Ctrl (on Windows, so I guess it's Cmd on Mac) is irrespective of the mouse position (requires extra scrolling). Zooming with Alt (discovered by accident after a few days, thanks InDesign!) is what I expected of zooming with Ctrl, but Alt also activates the menu bar selection mechanism, which results in opening one of the menus when I hit a key to select a tool after zooming... Why even introduce such useless pseudozoom and hide away the normal fully functional zoom?
Many operations require repeated clicking - for instance, I want to change the glyph width, so I click the width value to get to the text input and change the value or shift it, but the field isn't activated; I have to click again before it is focused. Similarly, many operations require, by design, double clicks, but because of the low responsivity or bad design of the whole GUI it turns to triple or quadruple clicks. It is not always clear which segment of the GUI is focused, so trying to switch tools with the key shortcuts not always succeeds. When you insert an element reference, it is selected in the drawing board, however in the elements panel it is not, creating an uncertainty as to which element is actually selected.
The undo command... bi*** please. The help forum thread on this issue is marked as "solved" even though there is not even a single answer to the initial post! Not only does "undo" undo an arbitrary amount of actions, and work globally instead of locally within one glyph (I guess the reasoning was to enable undoing font-level actions... not sure if that's possible anyway), but also the "redo" command works in an arbitrary order and sometimes, well... doesn't.
Which leads to the next issue... Googling phrases like "X not working in fontlab" yields no useful results. (I see everyone uses Glyphs anyway).
Another typical rookie mistake: the glyph width indicator. Only clicking precisely in the area of the text enables the input. Clicking within the marker but not on the text doesn't. This is similar to the Google search bar which looks like it has heaps of padding but actually is a tiny input with no padding wrapped in another div whose border pretends to be the input's border.
Also clicking on an off-curve point displays the absolute coordinates of that point whereas a vector from the on-curve point would be 300% more useful...
Copying a layer into another... seems to not work, the workaround being creating a new layer as copy of another.
Copying and pasting elements... It seems the learning curve to this supercomplex feature is steep. I figure there is no such thing as nested elements, so the way out of this is using components? But I really don't understand why the elements pasted as reference sometimes are pasted as new elements (with ".1" appended to the name). And first of all... are elements shared between masters? I thought not because when I changed one element in the new master, the one in the original master didn't budge. But then I edited another element... and the element in the original master was still linked to it. I unlinked it and renamed it, well, to the same name as it was before and then it magically wasn't linked any more.
And then to my horror it appears that inserting an element reference also inserts a reference to another master.
I suppose money is being asked in return for this early access beta to support its development?


  • Thomas PhinneyThomas Phinney Posts: 1,875
    Not only does "undo" undo an arbitrary amount of actions, and work globally instead of locally within one glyph (I guess the reasoning was to enable undoing font-level actions... not sure if that's possible anyway), 

    It is possible to edit across glyphs in normal editing, if you have enabled it. And Actions can easily affect multiple glyphs or the whole font in one go. So that's a complicated issue.
  • Adam JagoszAdam Jagosz Posts: 611
    edited May 2019
    Thanks Thomas for the insight. Indeed, I have noticed the Edit checkboxes. So that nullifies that one concern. But the folk at FL are aware that the undo doesn't do its job properly?
  • Thomas PhinneyThomas Phinney Posts: 1,875
    Unfortunately, it's a question of particular Undo-able actions that are not recorded properly on the Undo stack. So there have been a ton of fixed bugs in Undo. Clearly more need to be quashed. But it is a matter of specifying in a bug report exactly what it was that did not Undo.

    My personal experience is that Undo problems are pretty rare now—but of course I report the few I see, and they get fixed. So I am not shocked that some folks have a different experience.
  • Adam JagoszAdam Jagosz Posts: 611
    edited May 2019
    Agreed, the malfunctions depend immensely on the actual actions. I'll try to take notes of what goes wrong.
    The problem is that though the malfunctions are not that frequent as suggested by my initial impression, they are so surprising and spectacular that I can't begin to think what kind of information I could include in the ticket to help solve the issue. Just right now: Ctrl+Z resulted in the whole font file being reverted to the state from about an hour ago, with no "Redo" option available I think, or at least not "redoing" the last hour of my work with a single keypress (thankfully I saved it a minute before, and even if I didn't, autosave would literally have saved me). I understand edition history is a complex topic that can be approached with a variety of methods, often combined for more efficient handling of the feature. But in this case... I sense it's a leaking tap fixed with layers of duct tape situation. A serious redesign would seem more appropriate.
    I filed an issue with an autosave and the file saved after undo failed. I wonder if that can help beyond just proving that the issue exists.
    The malfunctions are especially malicious because sometimes you lose 2 minutes of your work without even noticing it (if it were minor tweaks) and this way you can choose to either never use Undo or deal with the fact that you're going to be perfecting your font forever. With FontLab the statement "A font is never finished" has a more substantial meaning.
  • These reported experiences are not so encouraging as I was going to upgrade… :-(
  • Adam JagoszAdam Jagosz Posts: 611
    edited May 2019
    I gotta admit the support is rather helpful though. Some of my remarks have been duly noted and others were resolved as just my ignorance :blush: Also this all is coming from a FontForge user who was trying out a paid font program for the first time and expected, well, no bugs for a change. But we'll get there, with my relentless demands, I hope.
    The Undo/Redo bug has not occurred again after some three times, but maybe it's thanks to my now incessant Fear of Undo.
  • @Adam Jagosz Thanks for the follow-up. I’ll have to upgrade regardless.
Sign In or Register to comment.