ERROR: invalidfont

Hello,

I exported a correct OTF-data from Glyphs, but some customer got problems with it:


TextEdit (OS X 10.9.5) OR
MSWord2010 (OS X10.8) OR
Pages (5.5.2 2120 + Yosemite) OR
keynote (6.5.3 +Yosemite) OR

=

ERROR: invalidfont OFFENDING COMMAND: definefont
STACK:
/Font-dictionary- /MCLEPS+MyFont-Bold

— Problem seems to be the Bold weight/instance (which is stylelinked to Regular)

— On OS X 10.10 the Bold weight can be printed without any error.

— Exported the files with Glyphsapp, with uses the AFDKO syntax


Would appreciate any idea where this Error comes from.
Thank you!

Comments

  • Send it over, mate!
  • jakob_rungejakob_runge Posts: 18
    edited June 2015
    besten dank! datei ist unterwegs.
  • Sorry, can’t find anything that might cause the problems …
  • attarattar Posts: 209
    edited June 2015
    Have you tried to decompile it with ttx and inspect the output?
  • hej adrien, I not that deep into ttx — but I guess I have to get into it to do do good font-production.

    Georg Seifert also tried to solve this and did not found a problem — so it could be a problem of that specific printer the customer is using.
  • Thomas PhinneyThomas Phinney Posts: 2,096
    The error message is clearly a PostScript error, and from the context it sounds like what is being printed (or attempted to be printed) might be a subsetted font in a PDF. The first thing to find out would be the exact model of the printer and whether it's Adobe PostScript, and if not, what it is. PostScript "compatible" printers vary wildly in their reliability/compatibility.
Sign In or Register to comment.