Black space character in InDesign: Ligature bug

If you create a white on black font, you don’t want a gap between words, so you fill the space character with a black box.
InDesign, however, seems to (still) insert spaces on top of ligatures, and therefore destroys the ligatures with black boxes.

Has anybody figured out a solution to this?

The only workaround I found is leaving the space blank and inserting an calt feature exchanging space by (a black) space.alt.
This fixes InDesign but creates gaps in non OpenType-savvy applications.

Comments

  • Craig EliasonCraig Eliason Posts: 1,162
    What purpose does the white-on-black serve? Is that an effect that could be better accomplished in the layout program?
  • That might have been the best solution, but the customer ordered it like that.
  • One solution I could think of would involves some context features that use glyphs with a wider background box that would overlap the space. 

    And doing the same thing in a layout app might be tricky as you can see through the white spaces in the glyphs. There are some transparency settings in Indesign but they might not print well.
  • My Reo is a two layer font where the first layer is solid background and the second has stripes, including through the space. I 'solved' that with alternates. A space.salt glyph that's a solid black rectangle for the first layer and stripes for the second. As long as stylistic alternates are on, it works as it should. 
  • Investigating this internally.
  • Confirming that this is an issue in InDesign CC.
    However, the issue no longer exists in InDesign CC 2014 (I am using version 10.2.0.69 to test this).

    CC 2014:

    CC:


  • Thanks, Frank. Good to know.
Sign In or Register to comment.