TTF Export Switching Glyph Slots

When I export my fonts to TTF in FontLab and load them in InDesign, some of the glyphs have switched slots. I've got "en dashes" where "n tildes" should be. "Ham" where "burgers" should be—and so on and so forth.

Basically, anything where I have to press the "option" key is "effed."

OTF versions are fine. Any insights?



  • Have you tried clearing your system font caches? Uninstalling the font(s), restarting, reinstalling the font(s) usually does the trick, among other ways.
  • Thanks, Mark. I tried that and also reexported the fonts and reinstalled. I'll give it another go and see if that fixes the problem.
  • I use Font Explorer for my font management. Cleared cache, deleted font files. Reexported fonts in FontLab, loaded them in Font Book this time. Opened InDesign. Still not working.

    Could it possibly be my ascender and descender measurements? Tildes and accent marks extend beyond the ascender measurements.
  • I could never get Font Explorer and the like to properly clear caches, the only thing that ever works is FontNuke.
  • Georg SeifertGeorg Seifert Posts: 667
    edited January 2015
    Terry, check this: it is written for Glyphs but the same workflow can be used from FLS, too.
  • Thanks, Georg. Gave that a shot but the problem still persists. This is a screen grab of what it keeps doing.
  • can you try with a different font family name? This may still be a font cache problem.
  • Try nuking all of your caches in single-user mode with Applejack:
  • You're not installing both the TTF and the OTF at the same time, right?
  • Mark, yes I am, but I have them named different. Does that matter? Sorry if these are rookie mistakes.

    Also, my HD appeared to be corrupt and I had to run Disk Utility several times to repair the problem.

    James, downloaded it and it says I can't be logged in as a user to run Applejack? (Running this script while logged in as a user can crash your operating system)

    Not sure how to install this.

    My apologies for all the questions—I really don't know very much about programming and these problems are really stumping me.

    Thanks for the help.
  • All the cache problems can be avoided if you don't install the fonts in the system fonts folder. So change the family name and put them in the Adobe fonts folder.

    And have you checked if the fonts are OK? Maybe you have some strange reencoding going on?
  • Hi Terry,

    For a closer look into the guts of your OTF and TTF fonts, you could give the free OTM Light 3.7, which you can download from here, a try.
  • John HudsonJohn Hudson Posts: 2,872
    In FL 'Options / Generating OpenType PS, OpenType TT and TrueType' parent panel, make sure that 'Automatically reorder glyphs' is NOT checked.

    In FL 'Options / Generating OpenType TT / TrueType encoding' child panel, make sure that 'Use following codepage for first 256 glyphs:' is set to 'Do not reencode first 256 characters'.

  • John—THAT DID IT. Thanks a million!
  • Many thanks to everyone for helping me troubleshoot! :)
Sign In or Register to comment.