Decomposing glyph in FontLab but resulting outline lacks tt instructions from source glyph

Options
Hi,
I'm currently hinting a set of glyphs in a single FL file that will later become two fonts. (I'm doing this because both fonts will share many glyphs.) I noticed that when I'm decomposing a composite the TrueType hinting instructions are all gone.
Does anyone have an idea how to keep them when decomposing?
Thanks

Comments

  • Paul van der Laan
    Options
    Strange, I don’t see that behaviour on my side (FL 5.0.2 on OSX).

    When I decompose a glyph where the base glyph has TT instructions, then these instructions are all there in the decomposed glyph.
  • Martin Wenzel
    Options
    I thought it was odd. I guess it’s a 5.1.2 bug then, that's the FL version I'm running under OS X
  • Martin Wenzel
    Options
    I was right/wrong:
    - glyph is made up of only one component: instructions are lost
    - glyph is made up of more than one component: instructions are intact
  • Thomas Phinney
    Thomas Phinney Posts: 2,787
    Options
    You might want to try 5.1.4, as that is the current version. I would definitely want to know if the bug is still present.

    Christoph: by "same" do you mean same as Martin (you see the bug in Windows) or same as Paul (you do not see the bug)?
  • Ramiro Espinoza
    Options
    The only problem I ever had decomposing hinted TTF contours was that quite frequently the instructions from the diacritic and the ones from the base character don't work well together and you must tweak the instructions to solve the errors. So be careful with decomposed instructions.
  • Martin Wenzel
    Options
    Hi Thomas, it's choppy (5.1.4 Mac).

    I've tried various combinations and I found that TT instructions stay intact in the following cases:
    - open glyph with multiple components, then decompose
    - select glyph with single or multiple components in font window, then decompose

    but they are lost in the following case:
    - open glyph with single component, then decompose.
    This at least is true most of the time! Switching the TT hinting mode on and off before decomposing and/or changing the glyph your viewing (using next and previous glyph) seems to have some effect on the "survival" of the instructions. I tried a lot, spent quite some time on this but I just could not establish a proper pattern.)