Options

Diacritics clipped in consecutive lines

Mithil MogareMithil Mogare Posts: 38
edited June 2023 in Type Design Critiques
I am design one font for first time in FL7. The em square is 2048. I have exported font as per industry standard, but in the adobes' product the diacritics are clipping or overlapping in consecutive lines even if i set leading to (auto) but in the figma the font is rendering proper line spacing (leading) on auto value. 
I tried varying the line spacing but it is giving same result. I am attaching the SS of font info. 

1. can some one help me to identify the root cause? 
2. can someone guide me to resolve this issue?



Thank you!
Tagged:

Comments

  • Options
    Thomas PhinneyThomas Phinney Posts: 2,749
    Show also the font dimensions? This does not show the cap height or x-height.

    I can, however, guess from the large “safe top” and “safe bottom” values that perhaps this font is way too big on the em square? A typical cap height is about 70% of the em, around 1400 on a 2048 em, more or less (+/- 100).

    Some more typographically savvy apps do line spacing based on a % of the em, and the default is generally 20% more than the em square. Adobe’s products are in this category.
  • Options
    Michael RafailykMichael Rafailyk Posts: 141
    edited June 2023
    • By default, Illustrator used actual ascender height to calculate vertical position of the first line in the bounding box. To change that, open menu / Type / Area Type Options, and change the First Baseline to what you need.
    • By default, Illustrator set up leading to 120% of UPM. To change that, open the Character panel and change leading there (the next dropdown menu after the Font size).
  • Options
    Igor PetrovicIgor Petrovic Posts: 263
    edited June 2023



    Here is the relationship between values.

    The "Line Gap" on the drawing is the value you define for your font in the font-drawing software, in your case Font Lab.

    "Safe Top" (ascender+line gap) and "Safe Bottom" (descender+line gap) are simply resulting (generic) values.

    "BBox Top" and "BBox Bottom" are actually the highest and lowest points in your font, and they should not exceed the UPM+LINE GAP area. 

    Actually, it's a good practice to keep your "BBox Top + BBox Bottom" somewhat smaller than "UPM+LINE GAP", about 5-10 units (@1000 UPM) to avoid any possible contact between the lines of text. Since the caps diacritic area is usually very tight, this usually means your actual descender "BB Bottom" is a few units smaller (closer to the baseline) than the defined "Descender" value.

    Also, on THIS LINK is the answer that @Thomas Phinney gave me a few years ago on a similar question, with some additional useful information.
  • Options
    John HudsonJohn Hudson Posts: 2,977
    edited June 2023
    Igor’s advice works okay for typical Latin fonts for western European languages, but there are plenty of writing systems, including some Latin ones such as Vietnamese, where the relationships between vertical metrics and heights/depths of individual glyphs get more complex.
  • Options
    Show also the font dimensions? This does not show the cap height or x-height.
    Here are other dimensions.
    A typical cap height is about 70% of the em, around 1400 on a 2048 em, more or less (+/- 100).

    Some more typographically savvy apps do line spacing based on a % of the em, and the default is generally 20% more than the em square. Adobe’s products are in this category.
    Should I decrease the font dimension by increasing the em square only?
    How does prof people tackle this problem?

    Thanks.
  • Options
    • By default, Illustrator used actual ascender height to calculate vertical position of the first line in the bounding box. To change that, open menu / Type / Area Type Options, and change the First Baseline to what you need.
    This is not showing any change.
    Also, I generally use the leading option to set a type.
  • Options
    Thomas PhinneyThomas Phinney Posts: 2,749
    Yes, that is what I suspected might be the problem. You have a cap height of 1911, which is about 93% of your em instead of 70%.

    The simplest way to fix the problem is to increase the em to ~ 2730 (without scaling glyphs!). 2800 would do nicely.

    The other possibility would be to scale everything (glyphs, advance widths, kerning values) by about 73%. This keeps a more traditional em square value, which is a minor benefit. However, you will notice that when the contours are rounded to the grid, you will have minor inconsistencies in stem thicknesses. Either you live with these, or you go through and fix every glyph. (FontLab at one point had options to avoid this, if you used hinting. I am not seeing those now, however.)
  • Options
    I played with some sizes and dimensions, I reduced (scaled) the em size with all dimension to 1700 and increased the em size to 2048. Now the caps height is 1241, xheight is 1154, ascender height is 1376 and descender size is -243 with 452 line gap.

    Thank you everyone for increasing my knowledge about em sizing.
Sign In or Register to comment.