Newly installed fonts don't appear in Pages' font menu on macOS

Roel NieskensRoel Nieskens Posts: 177
edited March 21 in Font Technology
What makes a font show up in Page's or TextEdit's font menu? If I take a font that is on the list, decompile, rename it, recompile it, and install it, it won't show up. The only thing that I changed is the name of the font in the name table. TextEdit will find the font when you go through extra steps to reach "All fonts".

I figured macOS would prefer families with a few styles over a single font, so I tried this with a whole family and still the same result. I used the existing modified date on recompile, in case macOS doesn't like brand spanking new fonts, also same result.

Are there any heuristics for when macOS deems a font good enough the be shown in the main menu of Pages or TextEdit?

EDIT: searching online gets results for users who can't find their freshly installed fonts either, to which people recommend workarounds without really addressing the problem. I can't find a thread here, though I'm sure I've read about something similar once.



  • Florian PircherFlorian Pircher Posts: 161
    edited March 21
    Pages only shows fonts that are deemed good enouth to support your current language. If your font does not (often the case with quick experiments), it’s only accessible from the ⌘T Font Panel.
  • Roel NieskensRoel Nieskens Posts: 177
    The language support remained unchanged. Like I said, only a single letter in the font's name changed, for the rest it's identical. The original font is listed, the derived copy isn't.
  • c.g.c.g. Posts: 47
     The only thing that I changed is the name of the font in the name table.

    Maybe the font is CFF and you didn't change the names in the CFF table too?
  • Which fields in the name table did you change? 
  • Jens KutilekJens Kutilek Posts: 304
    IIRC this behaviour of fonts not showing up immediately started with macOS 13. A reboot should make the fonts appear in the menus.
  • konrad ritterkonrad ritter Posts: 194
    I had that problem a few times in the past, on macOS 10.2 and 10.3. One thing that worked for me was this approach:

    Close Pages. Open FontBook. Select newly install font. Right-click, then select 'Validate font.' If it validates without warning messages or problems, the next time you open Pages the new font should appear listed, ready for use. Good luck!
  • Mark SimonsonMark Simonson Posts: 1,568
    I find that quitting the app and relaunching it usually works.
  • Roel NieskensRoel Nieskens Posts: 177
    Thanks everybody for your suggestions. Turns out @Jens Kutilek's trick was the one that worked: reboot the machine, and the font is finally there. Indeed it seems like this started with 13 (Ventura). How very inconvenient! Also it seems it is out of our control then. Makes me nostalgic that "turn your computer off and on again" is still a fix in 2023!

    @c.g. @Daniel Calders I did a find and replace across a .ttx of the font, so it also changed the name in the CFF table. I changed only only letter: my original font was Vulf Mono Code, which I changed to Fulf Mono Code.

    @konrad ritter Thans for the suggestion. But the font was actually 100% validated!
  • Roel NieskensRoel Nieskens Posts: 177
    Some further investigation shows that quitting the fontd daemon (the "Mac OS X system font registration manager") makes the font show up. Right after killing the process from the Activity Monitor, fontd will restart and presumably take stock of which fonts are currently installed.

    A little less annoying than having to reboot!

  • “font daemon” perfectly encapsulates its tormenting nature.
  • Please send feedback to Apple about this bug: or

    I've reported it during the Ventura Beta, but the issue is still 'Open' without any response. Perhaps if more users report it they may try to fix it.

    If you want to restart the fontd daemon using Terminal you can use the following command:
    launchctl kickstart -k gui/`id -u`/

    This will tell the daemon manager (launchd - 'daemons' are just background processes) to restart fontd for the current user (id -u). You can use it in a script so you don't have to manually open Activity Monitor and look for/kill the fontd process.

    It's interesting that only Apple apps seem to have this bug (TextEdit/Pages/Numbers/Keynote). The regular font APIs for developers don't seem to be affected. I suspect that the Apple apps use the 'English' list for the font picker and this list isn't updated automatically.

    The default font picker (Format › Font › Show Fonts) shows activated fonts right away in the 'All Fonts' list, but not in the 'English' list. After restarting fontd the same font will show up in the 'English' list.

  • Roel NieskensRoel Nieskens Posts: 177
    @Floor van Steeg Thanks, that's very helpful!

    Is there a link to your issue so we can +1 it, instead of making a new one?
  • The Feedback Assistant ID for the report I submitted is: FB11453612
    Unfortunately I don't think these reports are public, so giving a +1 is not possible as far as I'm aware.

    Perhaps best to create a simple report about how fonts you activate using Font Book are not visible in TextEdit / Pages. Only after rebooting the Mac the fonts become visible in the font pickers.

    You can mention FB11453612 in your report.

Sign In or Register to comment.