OTF Font appears empty in FontForge

I am trying to open an OTF file to edit it and remove all the characters I do not need (the file is a Korean font, so it is quite large). When I open the file, every character except A-Z a-z is blank. I have tried opening the file on both Linux and Windows and I'm getting the same result. The font is Noto Sans Korean from Google. I have tried downloading from other sources besides Google, same thing. Is the font restricted in some way that it won't let me edit it? 

I searched online and found this similar post, but changing the .bat file's language to Korean and hiding the unused glyphs did not resolve the issue. 

I am using the latest release (AFAIK) of FontForge, 20220308.

How the font appears when I try to open in FontForge:

When I select "Encoding->Compact":



  • Options
    Thomas PhinneyThomas Phinney Posts: 2,767
    I believe you are dealing with a CID-keyed OpenType CFF (.otf) font.

    Check out the CID menu, and select a different CID range. You are probably looking for the Hangul, but there are many other ranges in this font.

    You could also choose the “Flatten” option on that menu, which would be convenient for viewing, but will prevent round-tripping the font in the same format.
  • Options
    bobrobbobrob Posts: 2
    @Thomas Phinney Perfect! That was it. Thanks so much!
  • Options
    Thomas PhinneyThomas Phinney Posts: 2,767
    You’re welcome. The source of the problem is definitely non-obvious!
Sign In or Register to comment.