Can't update sidebearings of composite glyphs in FL7

Vasil StanevVasil Stanev Posts: 751
edited October 2021 in Font Technology
I did some changes to sidebearings after I had done the extended latin and have no clue how to update the metrics of the composite glyphs. I haven't done anything fancy and expected them to update automatically. And the official manual still isn't updated  ;) - I can't see  a Font>Update metrics anywhere. Am I missing something?



Comments

  • Hello Vasil,

    I read in the Fontlab Manual (more precisely in the release notes of version 6.1.3.7013, under the title Live update of metrics and auto layers) the following explanation:

    In previous versions, FontLab was always automatically recalculating (updating) the location expressions and auto layers whenever you changed some glyph, and was updating the linked metrics either automatically (when the global setting Preferences > Spacing > Automatically update linked metrics was on) or manually (when you triggered Font > Update Metrics).

    We have now removed the preference and added a new submenu Font > Live Update. It contains two checkboxes: Live Metrics which causes FontLab to always update the glyph metrics that use expressions, and Live Auto Layers that causes FontLab to keep rebuilding the automatically generated composite glyphs.

    If your font uses many auto layers or many linked metrics, live updating may be slow and can impact the performance of FontLab. If that’s the case, turn off either of those checkboxes and periodically trigger Font > Update Glyphs (AltCmdM) to force the update.

    FontLab now saves the state of the Live Update checkboxes inside your VFC/VFJ, so you can easily set one font to have live update on and another font to have it off.

    I hope this helps.

  • Remark: I should have asked on the FL7 forum.
  • Remark: I should have asked on the FL7 forum.
    I keep forgetting I have an account there. Overabundance has made me forgetful!  :D
  • Michael RafailykMichael Rafailyk Posts: 141
    edited October 2021
    One more way, for example for the letter A:
    — Select all A-related diacritic glyphs.
    — Actions (shft+cmd+T) > Metrics > Set sidebearings.
    — Left: Set equal to: A
    — Right: Set equal to: A
  • One more way, for example for the letter A:
    — Select all A-related diacritic glyphs.
    — Actions (shft+cmd+T) > Metrics > Set sidebearings.
    — Left: Set equal to: A
    — Right: Set equal to: A
    Works like a charm. I reward you with a virtual beer: (_)]
    Cheers. :)
  • And a bottle of wine for the "Update Glyphs"!
  • Michael RafailykMichael Rafailyk Posts: 141
    edited November 2021
    @Vasil Stanev
    I have to take a note about this approach, that you need to know.

    I found a problem with decomposing/flatting glyphs with letter-related (not a number) sidebearings, if the glyph contains Nonspacing element and this element extends beyond the glyph box. After decomposing, the nonspacing element become spacing and sidebearings should count it, and here the trouble.

    What happens when decomposing such a glyph with number specified sidebearings: the advance width of the glyph still the same and just sidebearing number has changed (to something minus), as expected.

    What happens when decomposing such a glyph with letter specified sidebearings: the glyph width increases by width of nonspacing element, and the sidebearing number still the same. That mean, if the sidebearing=H=40, after decomposing it's still =H=40.

    I think, decomposing action should have some option like "Flat a letter-related sidebearings to numbers" that should run before the main process.

    Actually, at the moment I stopped using letter-related sidebearings and just using numbers to avoid the possible problems.
Sign In or Register to comment.