Microsoft word stylistic sets bugs

Hi everyone,
I am trying to apply a stylistic set to an hebrew font but it does not work.
It works with Latin, cyrilic, greek and devanary but in hebrew I can't make it work at all.
It is a simple substutition: lamed  --> lamed.alt
Is there a way to make it work or it's a bug?
I am working with word 2019 windows 10.
Please, any help is welcome.


  • When this happens to me I usually have a typo in the substitution rule, or there is a conflicting rule somewhere that causes the substitution to not fire.
  • Thank You @Oliver Weiss (Walden Font Co.) , but the stylistic set works in indesign.
    I use microsoft VOLT to make the opentype features and I test all of them, there is no typo.
  • Did you remember to include Hebrew in your languagesystem declaration?
  • Hi André,
    Yes, my fonts have 2 scripts: default and hebrew.
    In hebrew I put 2 languages: default and IWR (hebrew)
    All of them have stylistic sets.
    All my fonts work correctly in Indesign and also in text viewer from DTL OTMaster 7.9.
    In Coreldraw I have the same problem.
  • Just in case the Right-to-left flag is on, turn it off for the stylistic set.
  • Thank You @Kamal Mansour, but How do I chance the rtl flag?

  • If the setting is RTL (right to left), change it to LTR. I am only mentioning this possibility because I've seen the flag interfere with similar operations in other contexts. Maybe you will be lucky!
  • Thank You @Kamal Mansour, I did this, but nothing changed
    I think this ia a big in rtl languages.
  • John HudsonJohn Hudson Posts: 2,973
    The issue may be in the MS Hebrew shaping engine, which is very old. It may simply not include the Stylistic Set features in the features that it applies. I will ping someone at Microsoft regarding this thread.
  • It appears that there's a design gap in Microsoft's Hebrew shaping engine, that it isn't processing discretionary features. I'd encourage people to use Office and Windows feedback mechanisms to report that as a bug.
Sign In or Register to comment.