Big Sur and font suitcase files

Mark SimonsonMark Simonson Posts: 1,377
edited January 21 in Font Technology
Mac font suitcase files are still recognized and supported on macOS Big Sur (11.x), but not over local networks anymore. The apparent reason for this is Apple reducing support for AFP (Apple Filing Protocol) network protocol. SMB has been the default at least since Catalina, but you could enable AFP prior to Big Sur, at least for HFS volumes. That option has been dropped.

Volumes formatted in APFS (which supersedes the ancient HFS) have never been able to be shared over AFP, so this appears to be part of Apple's ongoing effort to phase out HFS.

If you have a pre-Big Sur Mac on a network, it can still serve HFS volumes over the network and they are still recognized and mountable by Macs running Big Sur.

All this is preface to say that you need to be careful if you still have old font suitcase files that you want to maintain or continue to use. 

Font suitcases date back to the pre-OS X classic Mac OS of the eighties and nineties. The classic Mac OS file system supported files with two "forks": a data fork and a resource fork. The data fork was were user data was normally stored, for example in document files. The resource fork held metadata (such as file type and creator codes) and also system resources, such as fonts. Font suitcases were basically files that contained nothing but font data in the resource fork (and nothing at all in the data fork).

"Foreign" operating systems, such as Windows, UNIX, and Linux, have no support for this two-fork file structure and can only "see" the data fork. So if you copy such a file to such an OS, only the data fork survives and the resource fork is lost. Since font suitcases contain all the data in the resource fork, you end up with an empty file (zero k).

Mac OS X/macOS has always included some support for this non-standard file structure. You can still install and use ancient font suitcases on modern Macs for either Type 1 or TrueType fonts. (Not old bitmap font formats, however.) But SMB, which comes from the Windows world, does not appear to recognize resource forks even on macOS, so it's the same result as trying to move a font file to Windows or over the internet (which uses UNIX file protocols).

Consequently, if you want to preserve old Mac font suitcases when transferring over a local network under Big Sur, you will need to store them in a .zip archive, as if you were emailing them or moving them through a non-Mac operating system. Physical transfer, via a Mac-formatted removable media, still works fine.

FWIW, this is also the case with iCloud, although I don't know what file protocol is used for that. iCloud, for whatever reason, does not support files with resource forks.

I'm a little disappointed by this, but at least Apple hasn't totally dropped support for font suitcases.


  • Mark SimonsonMark Simonson Posts: 1,377
    That's a great tip. If one wishes to use legacy fonts on pre-OS X Macs or emulators, you would still need the old suitcase files. (I sometimes do this.)

    One other thing: Dropbox does support Mac files with resource forks including font suitcases, unlike iCloud.
  • Ah. I misunderstood. I thought you were talking about serving fonts over a network rather than transferring files. Yes, if you want to use the fonts in (e.g.) SheepShaver, you'd still need the original resource-fork based suitcases.
  • Mark SimonsonMark Simonson Posts: 1,377
    Yeah, I was addressing a potential data loss situation with Big Sur when you want to preserve legacy files.

    I'm probably more compulsive about saving things like this than most. I still have files (including bitmap fonts) I made on my 1984 Mac which I can work with in Sheepshaver and Mini vMac. (Not to mention even older Atari home computer files.)
  • Yep. I’m a regular Mini vMac/SheepShaver user. Out of curiosity, have you found a way to emulate Mac OS 10.0 through 10.4? Those are the only versions of the Mac System which I have been unable to get to run on modern hardware.
  • Loss of resource fork data is also something to be aware of if you're using a backup service like Backblaze. I lost many old fonts a couple years ago when I recovered a lost drive from Backblaze. I can't remember if it's because the drive they shipped used non-Mac formatting or if the backup server itself is SMB and thus does not preserve resource forks.
  • Mark SimonsonMark Simonson Posts: 1,377
    Out of curiosity, have you found a way to emulate Mac OS 10.0 through 10.4?
    I haven't tried that and don't know if it's possible. The only other old Mac system I run is 10.6 (Snow Leopard) using VMWare. This lets me run pre-Intel Mac OS X apps. It's actually the server version which I had to buy by calling a guy at Apple who then mailed me a CD-ROM.

    I also have a 2009 MacBook Pro with Snow Leopard on it. I used to have a lot of old Macs, but I got rid of most of them when I realized I could just use emulators and VMs.
  • Hin-Tak LeungHin-Tak Leung Posts: 323
    edited January 22
    Yep. I’m a regular Mini vMac/SheepShaver user. Out of curiosity, have you found a way to emulate Mac OS 10.0 through 10.4? Those are the only versions of the Mac System which I have been unable to get to run on modern hardware.
    I have had some success using pearpc specifically to get at early mac os x shipped fonts for testing font validator. It emulates powerpc hardware for the early powerpc based mac os x 10.0-10.4 :

    It was a few years ago so I don't remember much details (though I could look up my notes from then if needed).
  • Thanks! I'll check it out.
  • Mark SimonsonMark Simonson Posts: 1,377
    edited October 29
    Update: It seems that support for accessing suitcase files over a network has been restored in Big Sur. I happened to be looking through a folder of fonts, and noticed that the issue that prompted me to start this thread seems to have been addressed. AFP is still gone, but font suitcases are no longer reporting file sizes of "zero k" as they had been. I'm not sure when this happened. I had assumed that it was intentional or a side effect of dropping AFP, but now it seems to have been a bug and has been fixed. Yay!
Sign In or Register to comment.