installing robofab

I feel like a newbie.

I installed everything in a new machine and when I install Robofab_599_plusalldependencies following Ben Kiel instructions here

I have the following problem


Seems like the site-packages folder is not containing the stuff I installed (dialog kit, etc)

So of course when I run a robofab macro on FontLab I have the following errorimage

I am running 10.8.4 and FL 5.1.3

Any help?


  • I never used the installer. I download the source and copy the folders manually.
  • Paul van der LaanPaul van der Laan Posts: 238
    edited July 2013

    It will be best to try to do the install again following Ben Kiel’s video, and then check a few things out:
    • Do you get any errors during the installation process in Terminal? It is vital for instance that you enter the correct admin password.
    • Did it perhaps install all the stuff in another folder than “2.7”? (Have a look in “2.6” for instance.)

    Hope this helps, and otherwise report again here.
  • Ale PaulAle Paul Posts: 33
    I found that the stuff is inside another folder but I still have this error

    ImportError: No module named


    I reinstalled a few times following Ben's video. :(
  • It's been a while since I did this, but I think I copied the robofab junk from the 2.3 folder into the 2.6 and 2.7 folders. Worth a shot.
  • Chris LozosChris Lozos Posts: 1,433
    As I recall, I needed to look deep into the Library folder to find which set of folders was actually in use. There seems to be many duplicates but that may have been due to the many times I tried to install it before I finally succeeded.
  • PabloImpallariPabloImpallari Posts: 683
    edited July 2013
    This handy script by Erik van Blokland will tell you exactly which modules, versions and folders FL is using
  • Chris LozosChris Lozos Posts: 1,433
    Thanks Pablo and Erik!
  • Ale PaulAle Paul Posts: 33
    Moved files seems to work!
  • Did you mean you just pasted robofab and dependency to python 2.7 >Lib> Site packages folder? I did the same but still shows ImportError: No module named I am new to this. Using windows 10. I installed following web instruction. Is there a way to just put necessary folders there instead of installing?
Sign In or Register to comment.