FontForge Suddenly Exporting Corrupt Files. Can Anyone Help?

I was working on my font today and when I generated an .otf file I found it was corrupt. The .otf will install but none of the open type features I've programmed work in Adobe software. The validation through Font Book suggests errors in the kern table. 

Here is the thing that is leaving me totally confused. I have saved hundreds of versions of the .sfd source file. All previous versions of the source file result in the same corrupt .otf export in which the OTf features are broken. Previously these files have had successful exports. If I use FontForge to open previous .otf files of this font that are not corrupt and try to export a .otf from them I get the same corrupt result. This leads me to believe the issue is something wrong with my computer causing FontForge is suddenly producing corrupt fonts. 

Previous .otf drafts are installing just fine.

I have tried uninstalling and reinstalling FontForge and XQaurtz. I tried installing a 2017 version of FontForge and using to edit previous .otf and it exported the same corrupt files. I've also tried deleting all of the kerning classes and stylisitc sets and then doing another export to .otf which fixes the validation error for the kern table but all of the OTF features are still broken. I've tried deleting all of my Adobe cache and restarting my machine and that did not help either. 

Can anyone help me with any things i might try to move forward? Any suggestions for troubleshooting would help.

I think my next step is to get a friend to let me install FontForge on their machine and see if I can open the project and export successfully from there.

I have worked so hard on this font and have run into many problems like this with FontForge. I'm thinking at this point I'm so exhausted with it that I'd be willing to buy another software if I could use it to open one of my .otf drafts and move forward with my project. 



  • I just installed an older version of FontForge on another Mac. I was able to open my previous .otf files, make edits and export .otf files without any issue. This confirms that there is some problem with the way my machine is running FontForge. I am not sure how to address this but I'll be looking into it.
  • Have You checked, what options you have selected in Generate Fonts... → Options? FontForge remembers the selected options on the next .otf/.ttf generation. First of all check if you have the option Old style 'kern' unchecked. This option with .otf  causes errors in FontBook. Is option 'OpenType' checked?

  • @Grzegorz Luk (gluk) This worked! OpenType was somehow unchecked. Thank you so much! I didn't think to check the options window because I have never opened it or changed anything in it before. I'm not sure how it got unchecked and why reinstalling FontForge didn't return this setting to default. I was thinking something was off between FontForge and my OS. 

    This community has been such a great resource. 

    I'm trying to figure out what a Dummy DSIG table is. I did a little searching. Seems like its function is to allow older versions of MS Word to access OpenType features.
  • @Thomas Weakley it is enough to generate any font as .otf with changed settings once and the program remembers the 'Options' settings. It's always a good idea to check the settings before generating the font.

    Idea of DSIG is actually more complicated, but in short, according to the FontForge documentation:

    Dummy DSIG -- On MS Windows, a font with extension "ttf" will be marked with an OpenType icon if it contains a 'DSIG' table. FontForge can't generate a useful 'DSIG' table, but it can generate a useless, empty and valid one.

Sign In or Register to comment.