Issues with ligatures in FontForge

Hi everyone, a while back I wanted to create a font so I could use my self-invented script on a computer as well.
So far I have been using FontForge because it's free but a couple months back I ran into some problems with ligatures.
After following the instructions from design with FontForge and some other tutorials I have found online I got them working inside of FontForge. So when I type the components of a ligature in the metrics window, they get replaced by the proper ligature. But the problem is that I'm unable to get the ligatures working in LibreOffice after exporting the font as an OpenType font. So my first idea was to check if LibreOffice actually supports OpenType. I then installed the latest version that can definitely use OpenType features. After that I tested my font again, but still my ligatures weren't used. Has somebody got an idea what could be wrong?

Something not closely related:
I read that a new font design software called TruFont is in development. Would switching solve the problem with ligatures? Also, would switching be beneficial in general?

Thank you for your answers in advance.


  • You may need to share your FontForge file or the OTF to for us to see why it isn't working in LibreOffice.

    And while Trufont is promising, it still has a long way to go before it can do many of the things we expect in a font editor. Development seems to have stalled without a single commit to Github (at least publicly) in almost two months.
  • Does Writer require the silly tag codes for ligs? If so, are you using it?
  • @Mike Wenzloff:
    ligatures are a default-on tag, so they work without it specially enabled. I also tested it with some fonts that were preinstalled and there ligatures worked, also without the tag specifically set.

    @AbrahamLee if I try to attach the font files, it says: File is not allowed.

  • Maybe PM me?
  • Finally... Here come the font files. For one the FontForge file and second the exported OpenType font.
    I've compressed them as a tar.gz archive to be able to attach them here.
  • The OTF has no features in it.
  • Did you create an AFM file to stock your ligature infos like on the attached image ?
  • I have tried your otf with LibreOffice and it did not work. I generated an own otf (with standard options) from your sfd source and it DID work with LibreOffice. Updating to a newer version of fontforge may help (mine is from october 2016). If this is not the case, you must have chosen strange options in the generate menu.

  • Mine is the same experience as Linus.

    Incidentally, when I open the OTF in FF, I do see the Ligature lookup there, but I think something got jumbled because the subtable name isn't remotely close to the one in the SFD file. You'll probably want to change the name to 'liga' since that's the standard ligature subtable name.
  • Thank you guys! I have just had a look at my fontforge installation, and indeed I've only got a version from 2012 installed. That's because the ubuntu package archive doesn't update fontforge for xenial any more. So I'll have a look if I can't update it anyway and see if that already solves the problem. And if something still doesn't work I'll come back.
  • Perhaps you could install the ppa version on ubuntu. It works fine for me on kubuntu 16.04 LTS.
  • Hi ivan, it's exactly what I've done. Now ligatures work all fine. FontForge only can't read my custom encoding any more...
  • Did you subscribe to the FF users mailing list ?
  • Regarding the encoding: Did you think of loading your encoding file again into fontforge? (Menu Encoding/Load Encoding)
  • Yes, I have thought of loading the encoding again but felt like something wasn't exactly the way it was before. I don't know if something really has changed at all, but then I updated the encoding a bit and also branched off to a new file. So this problem is solved now too and I just have to draw the remaining characters.
Sign In or Register to comment.