Unicode naming with the append glyph function (Fontlab)

Options
André Simard
André Simard Posts: 185
edited February 2013 in Technique and Theory
With Fontlab is there a way to keep unicode number when I append a glyph? I drew a roman font and all unicode and naming work well. Now I want to draw the italic one. So, I start from an italic vbf file I've already drew as a basic file and I want to import the new glyph I've inserted in the roman one. When I import it I lost the unicode name. Is some typophile user has a solution to append a glyph without lost the unicode number? I hope the problem description is clear enough.
Thanks.

Comments

  • This isn't Typophile, but this problem sounds like it would be easy to solve with a few lines of python.
  • Thomas Phinney
    Options
    If you are pasting glyphs in, and losing the names, you need to paste them into the same slots. If you try to paste on top of existing glyphs a dialog comes up, and you have the opportunity to tell FontLab to overwrite what's already there. (Assuming that's what you want.)
  • André Simard
    Options
    @Thomas: I probably forgot something when I asked my question. Here some more detail. I start from a typeface in basic latin I've drawn, in this typeface I've add new language (cree syllabic) the good unicode number is well assign on each glyph. Now I want to import those cree syllabic glyphs drew in my roman to the italic typeface. So, I select all the cree syllabic glyphs from my roman and place it in the italic typeface using the append glyphs button in Fontlab. All the glyphs take place correctly with the good name but without any unicode number. So, I've to manually assign the unicode number on all the new glyph I've imported. I'm looking for a shortcut to keep the unicode number from my roman type to the italic one. Thanks.
  • André Simard
    Options
    Got it! A Typophile member suggest this and it works fine: For Fontlab: if your target file is set to Unicode, and your copy (from file) is set to Names, then if you copy and paste to the correct Unicode position in the target file, everything works fine.
  • PabloImpallari
    Options
    Have you tried: "Merge Font"? It should be easier I guess...
  • André Simard
    Options
    @Pablo: you’re ritht it’s much easier. I never try it. Tanks for your answer.