FontLab Help: kerning pairs are no longer grouped in the kerning classes I created

Lorenzo Miglietta
edited July 2017 in Type Design Software
Hey there!
I'm Lorenzo, Italian 23-year-old graphic designer and novice type designer. This is my first message in this beautiful and high quality community and... unfortunately I have a problem :(

I'm working till a month on my first typeface.

In these days, in particular, I'm working on the kerning.

I created all the classes (inspired by what other type designers did), and THEN worked on the kerning.

The kern opentype feature was fine, no problem.

Then I made the mistake to open with FontLab the .otf file instead than the .vfb. I edited some kerning pairs and save the file before I understood that was the wrong file.

Too late.

The new .vfb file has some problems in the kern feature: the pairs are no longer grouped inside the kerning classes I created!

Could you please help me on how to reverse this? Or what I have to do to put back things in order?

Thank you very much guys!


Here some screenshot:


  • Lorenzo Miglietta
    edited July 2017
    Ok, I solved this problem on my own :)

    I left here the solution in case someone in the future have the same issue.

    First go to Kerning Assistance (Tools>Kerning Assistance) and click "Compress".

    Then, open again the Kerning Assistance Window and generate a new kern feature.

    This will solve the problem ;)