MakeOTF error in Glyphs


OT features have been working fine for several months. Now I was just editing some glyphs (without changing anything in the features) and noticed this error.

I have an older version with exactly the same code and it works perfectly fine. 
Does anyone know what this is and how to fix it?



  • Johannes Neumeier
    When you go to Info > Features > calt you are likely to find the problem around the definitions that have to do with "s.beg_commaaccent" - either it's missing from the font, or renamed, or something the line just before or after is. If you are automatically generating the feature, refresh it. My first bet would be that a glyph of that name does not exit in the font - maybe a new update to Glyphs made it less tolerant to this particular error, or introduced some naming update that not makes your OT feature's referenced name redundant.

    Also the Glyphs Forums are usually a very good place to ask this kind of software specific problems.
  • Vitória Neves
    Thanks @Johannes Neumeier.
    The glyph is not missing and I did not update the Glyphs app. So that's not it.

    What I find weird is that if I copy the same code from the older version (that works fine), into this one, I still get this error. If I delete this bit, where the "error" is, everything's error free. 

    Already asked in the Glyphs forum. Let's see if someone can help.
  • Kent Lew
    Kent Lew Posts: 905
    A couple things to try:

    • Eliminate the space after the "s.beg_commaaccent" and before the bracket. The white space shouldn’t matter, but you never know.

    • Similarly, you could try deleting the line return at the end of that line and reinserting it. If somehow that line return got formatted incorrectly (LF versus CR, for example) then this could be throwing off the compiler. Just a guess.

    These are both long shots, but you could try. Good luck.

    Also, this has nothing to do with that error, but FWIW, in future it would be more conventional to name your alternate glyphs as sacute.beg, scaron.beg, scommaaccent.beg, etc., so that PDF reconstruction could lead back to the original codepoint.
  • Vitória Neves
    Thanks @Kent Lew
    Unfortunately none of those 2 things worked :(
    Also thanks for the naming advice. 

  • Vitória Neves
    Vitória Neves Posts: 19
    edited February 2017
    Thanks again @Johannes Neumeier and @Kent Lew. I fixed it. I had an invisible character. I must have deleted the "s.beg_caron " by mistake.