Cache clearing in FontExplorer X Pro

Curious if others have had trouble with the newer version of FontExplorer. I used the old free version since it came out and it worked perfectly for what I do. The last year or so when I upgraded my OS to Yosemite I would get bug messages, but they didn't really pose a problem. A few months ago I upgraded to the X Pro version. I'm finding the Clear Cache tools for the FontExplorer Font Folder and for applications doesn't really do anything. In the past it would take a deleted font out of the FontExplorer Fonts Folder. Now when I look there they haven't moved. I've been finding an older version of a font where I even manually deleted from that Fonts Folder still showing up even after rebooting. This makes it very difficult when I'm trying to fix issues with a font and cannot clear caches properly. I'm wondering if Font Explorer has a secret cache folder somewhere.


  • I've had a similar experience. Are you working in Adobe CC applications? Some of them, including InDesign, create a Document Fonts folder for each project into which copies of all the fonts you've been working with are placed. These have to be removed, too, if you wish to delete them from FontExplorer. 
  • I'm in CS5. I can't tell if there is a font cache folder for that in CS5, but after restarting and using a new document each time there shouldn't be an Illustrator cache of it. Same thing with Mac version of MS Word. I checked Font Book just in case it had it in there, but that wasn't the case either.
    I did a search using just Fontexplorer and it shows a metadata cache for fonts. at the bottome it lists the font by name, but in the actual file it's by number only. Since this is a Metadata font cache I'm not sure if that's an actual font or not, but I'm thinking not.
  • In the past I found FontExplorer font cache flusher to be unreliable so I started using Font Finagler. Never had a problem ever since.
  • Thanks Ramiro. I'll look into that.
  • I had the same issue with Macs OS Yosemite mainly in Illustrator and InDesign such as “strtable error” I found out FontExplorer did state there we‘re issues and suggested updating the plugins or to the latest version of FontExplorer which seemed to be the root of the issue. 

    For me their was conflicting issues among updates with Apple, Adobe that effected plug-in software as each issue resulted each company blaming the other when they updated their software if their software had issues.

    You can find a link to an article here

    However touch wood macOS Sierra it seems to be working ok. I do find FontExplorer can't handle too many fonts that creates issues in Adobe Illustrator and InDesign. And using fonts in Photoshop forget it loading is a nightmare. I keep it below 1000 fonts installed. 

    This handy site that helped me, explain clearing cache

    If anyone has any other font management systems let me also.  

  • Do you mean 1000 fonts activated, or 1000 fonts known to the app?

    Not having a lot more than 1000 activated fonts is probably wise, although I have often been around 1500.

    The other serious font management app is Extensis Suitcase, which is mostly what I use, although I have flirted with Font Explorer as well.
  • Do you mean 1000 fonts activated, or 1000 fonts known to the app?
    Sorry I should of stated clearly, I meant installed (into the app) and activated, for reasons that Photoshop doesn't like type when it comes to loading loading fonts.

    Not that I use type in Photoshop (that's a topic for another day) there have been cases which I had to use type for quickness sake. Since updating the Mac OS Photoshop and Font Manager the performance is slow compared to my other MacBook that is on an older version of OS, Photoshop works harmoniously with Font Explorer. 

  • Michael JarboeMichael Jarboe Posts: 265
    edited November 2016
    In my experience, FontNuke is the only app that has ever worked reliably for clearing font caches.
  • The user and all related content has been deleted.
Sign In or Register to comment.