Odd Font Issue - Language

I have been trying to figure this out for a while now: 
My font (highlighted) shows up with oriental preview characters and shows up in the font menu in its own category, even though it is a standard Latin font. This behavior started suddenly, without any changes to anything but glyphs. Does anybody have any idea why? I have been through the font info carefully, but do not see anything missing or out of place.

(I am working on WIndows version of Fontlab Studio 5.2)

Thank you


  • I encountered this strange thing too some time ago with a font of mine, on the Mac.
    Complete mystery to me.
  • Something similar occurred to me, but the font was shown as Mathematical/Symbol. Later I discovered the issue was due to a checked "Mathematical operators" within this FontLab dialog:

    Of course, if you did not change anything here, it shouldn't cause such problem. But it may be a bug of FL 5.2 (I am using Mac and FL 5.1.5).
  • Could you please send the result of

    ttx -t OS/2 <whatever.ttf>
  • Chris LozosChris Lozos Posts: 1,458
    edited July 2016
    The Mac FontBook can have strange looks if you have multiple scripts in a font.  I used to have this issue with Greek, but not lately.  My font would contain both Latin and Greek coverage but FontBook would choose Greek as the language it displayed.  It would not show Greek Glyphs, it would show place-keeper icons for Latin that were Greek ;-/  I have no solution.  At some point, Apple or FontLab seems to have fixed it but I have no idea who or what.  I am now using Mac 10.10.5 and FLS 5.15 build 5714
  • Hi Igor. I looked into the section you pointed out, and although nothing looked wrong there, I fiddled around with it and somehow fixed my problem. Perhaps something happened when I converted the VLB from Typetool to Fontlab.
  • Glad you managed to make it work, Beau.
    For future reference: Just as in Igor's case I suspect the unicode ranges were not flagged correctly. If you happen to run into a similar problem, it's worth checking that first.
  • Sorry to bring this up again, but after a brief correction, the font is misbehaving again.
    The font looks alright in the preview window now, but it still shows up in the wrong place in the font menu. (Only in Illustrator. InDesign and other programs don't seem to have any issues.)

    I have tried everything I can think of to fix the issue. Changing the naming, encoding etc. I even copied only the Latin glyphs into a new font file. The issue persists. Now that does not make sense to me. It must be some basic setting in the naming I am getting wrong. I haven't had this problem with the other half-dozen fonts I have built. 

    Belleve Invis asked:

    Could you please send the result of

    ttx -t OS/2 <whatever.ttf>

    But I'm not sure how to do that. Is ttx -t a script?

    This is driving me nuts.

  • ttx is part of fonttools, a python based font manipulation tool set.

    You should get roughly the same sort of information and slightly more friendly, in the OS/2 section of the report from running font validator also.

    Or just e-mail the font to one of us and let us have a look...
  • Kent LewKent Lew Posts: 905
    I doubt the trigger is in the name table. I suspect this behavior has to do with the OS/2 UnicodeRanges. I think that when certain ranges having to do with non-Latin/non-Western scripts are checked, that’s when Adobe apps place fonts in these segregated areas of the menu. I can’t swear to it, and I couldn’t tell you exactly which ones.

    But check in FontInfo > Encoding and Unicode > Unicode ranges and see if there are any oddballs checked, like “CJK Compatibility Forms” or something like that.

    Also, when you’re testing installation, you will probably want to clear your font cache each time, just to make sure Adobe re-evaluates completely.
  • Still working to figure it out. I'll try cleaning the font chaches and see if that helps.
  • Never found what was wrong. What I did was rebuild the font, step by step copying over the glyphs and coding, watching for the error to pop up. It never did, so I believe that the original file must have been corrupted somehow during one of the Fontlab crashes. That is the only thing I can think of. Thank you to all who helped me, especially Peter Constable.
Sign In or Register to comment.