Mouse issues in Fontlab

Up until recently I've been using a Wacom Intuos 3 on my Mac in Fontlab. Recently the mouse became hypersensitive making it difficult to work with. Since Wacom stopped making tablets with a mouse I've switched to the wireless mouse that came with my mac. For most purposes this works fine except it can take getting used to the motion sensitive top of the mouse. What I've been finding most difficult is when it starts jumping glyph cells on me. I have my zoom function set up like I use in Photoshop meaning Command/Spacebar brings up the zoom tool and adding the Option key gives a negative zoom tool. When I zoom every now and the something triggers it to jump one or more glyph cells either forward or backward. I've tried to see if I could get this to happen on purpose just to figure out how I might avoid it, but it seems to only work when I'm cranking along doing things quickly. Just curious if anyone else has had that issue and perhaps found a workaround.

Comments

  • I use MagicPref to customize mouse scrolling and how mouse behaves in different apps. I'm not sure if it will solve your problem but it helped me a lot.
  • The user and all related content has been deleted.
  • StephenRappStephenRapp Posts: 59
    Key options for zooming are a possibility. I only changed it because I liked the finer control of zooming that I got accustomed to in apps like Photoshop. I had to turn off key commands for the Mac under Spotlight for this to function. I did manage to figure out how the mouse was causing me to randomly scroll through glyph cells. When I zoom using Command/Spacebar and then use my mouse to select my zoom size, my fingers have a tendency to move a slight bit on top of the mouse. Letting go of the spacebar first kicks in the scrolling. It turns out in Fontlab if I hold down the Command key and slide my finger left or right it will slide through glyph cells as fast as I move.
  • Luke FreemanLuke Freeman Posts: 61
    edited May 2016
    Tip, hold alt key and scroll up and down on the mouse to zoom in and out

    The reason it does this are you doing key commands as those done in Adobe?
    You only jump from glyph cell if you hold cmd and scroll on the mouse left, right, up and down
Sign In or Register to comment.