Robofab Installation MacOS 10.11.3

Hello!
I'm having trouble on installing Robofab and packages (Vanilla, DialogKit, FontTools). I'm using FontLab 5.1.5.
Just wondering if someone had this problem before, what could I try to do.

Comments

  • I’d love to see what I can do. What is the problem exactly?

    Did you follow the steps explained in Ben Kiel’s video?
  • Thank you, Paul! Actually, I did. But in fact, not sure if the files were written in the right location. Anyway, I tried to move them to the same directory of Ben's video, but no luck.

    Although, I still can run some scripts by using "from robofab.world import *". I have no idea what I should do in order to get things working fine. But, I can't make UFOs scripts to work. I'm having different outputs from different scripts.

    For instance, if I try to run "Import .ufo File into FontLab" this happens:

    can't import dialogs_fontlab_legacy2
    Traceback (most recent call last):
      File "<string>", line 6, in <module>
      File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/robofab/interface/all/dialogs_default.py", line 48, in GetFileOrFolder
        raise NotImplementedError
    NotImplementedError

    Or, if I run "Export Current Font to UFO Format", this happens:

    Traceback (most recent call last):
      File "<string>", line 9, in <module>
    ImportError: No module named robofab.interface.all.dialogs

    Could you shed a light on these, please? 
    Thank you very much!
  • The UFO scripts that you are trying to use are old, and apparently not updated to work with current setups. If you need to work with UFOs then I strongly recommend to use FontLab’s vfb2ufo.
  • I still use all the Robofab's UFO1 and UFO2 scripts, plus UFOCentral under Yosemite with no problem... I think there must be something else happening.
  • Perhaps it is related to El Capitan. I am using Fontlab 5.1.4 under Yosemite and have no problems running the RoboFab scripts in question.
  • Mark SimonsonMark Simonson Posts: 1,495
    edited March 2016
    I'm on El Capitan, but I haven't been using FL or many RoboFab scripts much lately (using Glyphs and Robofont). Occasionally, however, I do use Tal Lemming's UFO Central to get UFOs in and out of FL 5.1.5, which does still work.

    https://github.com/typesupply/fontlab-scripts
  • Bruno: did you download the latest version of RoboFab?

    https://github.com/robofab-developers/robofab
  • Hey guys! Many thanks for your suggestions.

    Paul: Yes, I did use that version, I might double-check, anyway.

    Mark: Thanks, I think I have tried those, but I will check this out, hope it works.
  • Mark SimonsonMark Simonson Posts: 1,495
    I'll also second the suggestion to use vfb2ufo. It's simpler and faster than running a script in FontLab.
  • Yes, it seems a good one.

    I was just wondering, if the case that I want to update only one glyph from FontLab into my UFO? Sometimes, when I export all the font and open in Prepolator, it messes the starting points. So, sometimes it's handy to update only a glyph. Does it makes sense?
  • Chris LozosChris Lozos Posts: 1,424
    edited March 2016
    can you open the one glyph in Robofont, select the glyph outline; copy; open Fontlab file; paste into glyph window of Fontlab file; correct; then copy/paste back to Robofont?
  • Yes, it can be done. Although, you're adding a new step into the process. 
  • Mark SimonsonMark Simonson Posts: 1,495
    There are some older RoboFab scripts that do this (included with RoboFab), but I haven't used them in years. But, isn't it the whole point of Prepolator to fix things like that?
  • Yes, it is. But once it's fixed (import VFB2UFO, and adjust the starting points). If I import it again (the whole font, instead of a glyph) it messes up. It changes the starting point fixes done in Prepolator. It's not a big deal, but it's ideal.
  • Mark SimonsonMark Simonson Posts: 1,495
    If you import the UFO back into FontLab (via vfb2ufo) are the start points you adjusted in Prepolator changed?
  • Well, I haven't tried that script yet. I should. :)
  • Okay guys. The vfb2ufo is really very good! But, no luck on installing Robofab, and its scripts aren't working, such as UFO Central. Anyway, thanks for your help. I think it's a system, or Python installation problem. I like FontLab, but maybe it's time to let it go. 
  • Kent LewKent Lew Posts: 905
    can you open the one glyph in Robofont, select the glyph outline; copy; open Fontlab file; paste into glyph window of Fontlab file;

    This works superficially; but there are certain point types that translate differently, so one has to beware.

    A point that has only one handle — for example, the vertex in the notch of an n, where there is no handle on the stem side, only one contributing to the arch curve — will translate from RF into a “smooth” point when pasted into FL. The outline will be fine, unless you edit that bcp or its curve, at which point it will automatically start behaving as a tangent point, messing up your shapes unexpectedly.

    Copy/pasting back to RF from FL can also change your point indexes, depending upon the position of the start point. In certain circumstances, a start point that RF considers a single index, will be considered two indexes in FL and will be treated as such when it comes back to RF. It depends on the point type & structure.

    [At least, all of this is so with FL 5.1.4 Mac and RF 1.6 — your mileage may vary.]

    This copy-paste route can be used, but one has to know the pitfalls, understand how to work around them, and consider whether a given glyph will tolerate the round-trip reasonably without a lot of cleanup & intervention.

    Generally using vfb2ufo to translate back and forth is more reliable and consistent.

    If you want to update only a single glyph, then translate the modified FL back as a separate UFO, open it and paste the modified glyph back into the original UFO. That way any translation inconsistencies only affect the one glyph, not the entire UFO.
Sign In or Register to comment.