OSX Yosemite issues anyone?

I am trying to gather reactions to operational functionality issues (not critiques of UI or UI Type selection) in Apples newest OS revision. I am particularly interested in type design software compatibility and type use and printing issues which might affect a users choice to upgrade to Yosemite or not.
«1

Comments

  • I waited quite a long time to upgrade to 10.9 from 10.8.5; with Yosemite I did it immediately and have not encountered any problems.
  • Haven't found any 10.10 issues here. Mostly using UFO tools.
  • I upgraded on day one... and so far everything seems to be working fine... there are, however, two caveats:

    I had a minor issue printing to an HP Officejet which could have been my goof when I originally installed the printer drivers in Mavericks... this was fixed by removing the printer and reinstalling the drivers using the HP Utility app and not System Preferences.

    SMB sharing uses SMB3 not SMB2... so sharing folders can break (my HP Officejet can't scan directly into a network folder).
  • Chris LozosChris Lozos Posts: 940
    edited October 2014
    David: I am still on Mountain Lion but after a recent driver update on my HP P3005d (recommended via App-store), my printing ability died. I got a backup copy of my old driver and reinstalled it. Now it works again! Perhaps your driver issue was not caused by Yosemite after all ;-) I am about to banish HP and get a Ricoh.
  • As I posted in other places...

    Randomly I lose certain keyboard or cursor key functions. I was just editing a glyph and selected the tool to draw a circle from the toolbar. When I pressed 1 to return to the pointer tool nothing happened. I also lost the z and x zoom ability. Also lost was the delete key function and the command x for cut. These functions continued to work when selected via menu. When I pressed the ` key for high rez preview the preview remained after I released the key. Cursor keys continued to function.

    On other occasions I have lost cursor key function. It is all appears to be random. I will pay closer attention to see if I can identify a pattern.
    _____________
    And yes Chris, I have checked my keyboard preferences and nothing has changed.
  • 1)
    Well, FontShop found a bug when using OpenType Fonts with a higher UPM then 1000. Results in printing and display errors. I could only find a German information about it:
    http://www.typografie.info/3/page/artikel.htm/_/n/t/os-x-yosemite-hat-probleme-mit-opentype-fonts-r373
    Maybe try a google translation.

    2)
    On the other side, FontLab 5.1.4 has problems with an actual driver of the Wacom Bamboo/Intuos tablet: http://typophile.com/node/107749
  • James, are those are Fontlab issues?
  • That's interesting James, had something very similar happen the other day. It wasn't limited to Fontlab but that's where I noticed it first, but I'm still using Mavericks. Required a restart and hasn't happened since. Skeptical about updating to Yosemite.
  • I have had Wacom problems in FL in OSX 10.9.5 for a while.
  • Yes, Fontlab issues. Only Fontlab.
  • FontLab & Yosemite latest summary:

    The Wacom/FontLab issues in OS X 10.9.x can be resolved by going to an earlier driver. However, that earlier driver does not work in Yosemite, meaning the combination of the three is not good.

    In FontLab Studio, there are issues with viewing and editing font creation date in the Font Info dialog.

    We have one person reporting a broader issue with some keyboard commands randomly becoming unavailable over time while running FontLab Studio, but we have no confirmation of this. If anybody else experiences it, I'd like to know about it.
  • I upgraded to Yosemite on Day 2 and immediately found that some of my fonts did not work properly in it in Pages 5, Pages '09, TextEdit, or Nisus Writer Pro.

    I would choose a font, but the programs would not accept the change.

    Also, some some OpenType features (such as toggling from lining characters to oldstyle characters) in some fonts.

    I wish I had taken notes on which fonts acted weirdly, but I got so frustrated that I immediately switched back to Mavericks. I don't want to move back to Yosemite until I know my font library will work properly in it.
  • Indesign > Print Booklet, So for some reason indesign doesn't recognize PDF 9.0 as a default like before, so you have to install the drive from Adobe, what it does is recognizes only the connected printer so it wont let you set up a booklet larger than that, unless you install the drive. Or you can either use a plug in for adobe acrobat and don't do booklets in indesign. Not sure is many people use this feature but its something to consider (before you spend hours trying to figure out why doesn't work). Also this is a problem that I didn't had before updating to the new OSX
  • I upgraded to Yosemite and for some reason each first Python script I run in FontLab 5.1.3 (after a restart of the application), will start doing it’s thing after over a minute waiting. If I run the script again it work immediately. This also happens in FontLab 5.1.4. Someone else having this problem also?
  • I've got the same thing, Pieter.
    Using FL 5.1.4 4868.
  • I have submitted a patch to the robofab GitHub repository which gets rid of the initial delay:

    https://github.com/robofab-developers/robofab/commit/61048483f08e91370463c77477263053fc06e633
  • There is actually a Yosemite issue I’ve been trying to troubleshoot, but searching the web has made me believe I might be the only person who suffers from it. Not a single app seems to care about new font installs or, indeed, a Test Install in RoboFont – you could see why this might be a problem. Has anyone else seen this, or have I broken something locally?
  • Ramiro EspinozaRamiro Espinoza Posts: 519
    edited June 2015
    I've recently started working more on a new laptop running Fontlab and Yosemite and I've found the following problem: every time the Wacom pen enters the tablet's sensitive area Fontlab scrolls down the font view or the glyph view. I tried using another tablet but the problem remained and it's very annoying. Is there any solution to it? Will I have to join the exodus to the promised land of Robofont / Glyph? 
  • Ramiro, unfortunately yes, the problem you describe does not have a fix and is FontLab specific with regards to the Wacom. I have a collection of Wacom tablets and associated drivers and they all scroll unexpectedly to the bottom.

    This means you'll need to keep a machine around for drawing that is 10.9 or below. It's not fashionable these days to run old OS's but somewhere around 10.7/10.8 FontLab seemed to work the best, or the most :) These days I do a few things in FontLab and the rest in RoboFont.

  • Nick ShinnNick Shinn Posts: 1,091
    I contacted Wacom re. using my Intuos 2 on Yosemite, and they suggested I install an earlier driver: v6.2.0w4 (6.2.0w4). This works fine for me in Fontlab and everything else I’ve used on Yosemite so far—although I can’t adjust any settings.
  • Does anyone has experiences deinstalling an OS and installing a earlier version? I tried every legacy driver for my Bamboo Pen tablet and nothing seems to work well.
    I think the only option I have is deinstalling Yosemite and installing Maverick in my laptop.
  • I don't have experience going backwards and I know it was nearly impossible at one point... but if you upgraded and have been backing up with Time Machine, you can re-store to an old backup and OS. This assumes you upgraded and didn't start with Yosemite in the first place...
  • I don’t think it will work if you need your data (like Mail) to be migrated. You need to start over with a new system.
  • Nick ShinnNick Shinn Posts: 1,091
    You can transfer Mail data easily. 
    >Mailbox >Export Mailbox. Then import.
  • Data is not a problem because Yosemite is not in my main computer, just in a brand new laptop. I mainly work on a desktop Mac running Maverick. I have no problem completely erasing the laptop and attempting to install Maverick on it. All my important data and mails are still in the old desktop Mac running Maverick.
  • If it is brand new, it might not support an earlier system.
  • Ramiro EspinozaRamiro Espinoza Posts: 519
    edited June 2015
    "Brand new" from 3 month ago. I will ask the Apple service to see if it can be done. Thanks for the feedback.
  • Chris LozosChris Lozos Posts: 940
    Is this a Wacom problem or an Apple problem?  It seems one of them could help with a new driver?
  • Ramiro EspinozaRamiro Espinoza Posts: 519
    edited June 2015
    @Chris It's a Fontlab problem. Everything work fine with the Wacom drivers except Fontlab. The answer of the FL's helpdesk was "use an older OS" :/
  • Chris LozosChris Lozos Posts: 940
    edited June 2015
    The answer of the FL's helpdesk was "use an older OS"
    How wonderfully thoughtfull and customer service friendly of them ;-/
Sign In or Register to comment.