Threshold Pen for Glyphs - Project Request

I've been using the Threshold Pen script (http://robofab.com/howto/usepens.html) from Robofab for many years happily via FontLab but my workflow has changed to Glyphs and I'd like to use the exact same script in Glyphs.

While I'm aware of similar tools for Glyphs, I'd like to hire somebody to port this expressly to Glyphs so I can run it on the entire font rather just individual characters.

I'm also happy to OpenSource it for the community since it's a great script and if there is interest by the developer and the community. Feel free to message me directly or reply to this thread.

Comments

  • Filip ZajacFilip Zajac Posts: 16
    edited May 7
    We might try that. How urgent is it?
  • Jens KutilekJens Kutilek Posts: 156
    Theoretically, RoboFab-based scripts should work as-is in Glyphs. Theoretically, because I just tried ThresholdPen and it failed ... (after I got it running, it only leaves empty glyphs in the font)
  • Georg SeifertGeorg Seifert Posts: 509
    And there is the "Delete Short Segments" filter: https://github.com/mekkablue/DeleteShortSegments
  • Georg SeifertGeorg Seifert Posts: 509
    And I fixed the `ThresholdPen`, at least the sample code from the robofab website works now.
  • AbrahamLeeAbrahamLee Posts: 159
    edited May 10
    I apologize if this is too off-topic (I can certainly start a new thread), but speaking of RoboFab, does anyone here use the next generation of that code, called "fontParts"?
  • Stuart SandlerStuart Sandler Posts: 210
    Many thanks All!

    @Georg Seifert - Yes I tried the Delete Short Segments script with Rainer but found it worked very differently and had a different result.

    That said, if I launch the Macro panel and paste the script in, it's not running but I'm not sure where to download the updated 'fix' from that does get it running. FWIW, Robofab is not currently installed on this machine, so I'm not sure what assets I need to install in order to run the entire script.
  • Georg SeifertGeorg Seifert Posts: 509
    The fix will come with the next update of Glyphs. 
  • Dave CrosslandDave Crossland Posts: 928
    Isn't there a convencecon installer in the glypglyph preferences window?
  • Stuart SandlerStuart Sandler Posts: 210
    @Georg Seifert I just installed the 1141 update but was still unable to run the script. Kindly advise what I need to do in order to get it running, attached is the error.


  • Georg SeifertGeorg Seifert Posts: 509
    Do you have the latest version of robofab?
  • Stuart SandlerStuart Sandler Posts: 210
    edited May 24
    @Georg Seifert To be clear, I don't have Robofab installed on this computer because I wasn't sure what I needed to install.

    The latest install instructions I found were from 2013 for OS X 10.7 and located here: 

    Since I'm on 10.12 and it seems Robofab has been replaced with FontParts, it's unclear to me what should be installed. http://robofont.com/documentation/building-tools/toolkit/robofab-fontparts/

    Any suggestions are welcome and I'm sure your answers to me will help other folks in the future who find this thread.
Sign In or Register to comment.