Metrics Machine Spacing Issue

Hey guys,

I've got a quick question – hopefully someone can help!

Im in the process of kerning within Metrics Machine and drawing / spacing within Robofont. In the below image I've highlighted my spacing to show what the issue is. It's fine here in Robofont but when I open it up within Metrics Machine it shows negative values and all sorts of strange spacing. Anyone have a clue what's going on or is that just how it operates with italics? This is my first time within Metrics Machine and it only seems to be the case with my Italic...my roman is just fine!

I was recently interpolating as well and sadly, the spacing was all thrown off in the generated instance...How does one fix this? Again, only in my italics for some reason.

And here's the spacing shown in Metrics Machine: (-16, 42) on my H.

Comments

  • James PuckettJames Puckett Posts: 1,439
    Fonts don't actually have slanted side bearings. Glyphs and Robofont compensate for the italic angle so it's easy to think about the numbers. Metrics Machine predates the modern font editors and just shows the real side bearings values.
  • Do you have "slant point coordinates" enabled in the preferences in Robofont?
  • @Mark Simonson
    I do not! Would turning that on do the trick? 
  • @James Puckett
    Ahh that makes perfect sense – so what you're saying is, I have nothing to worry about? :)
  • Sorry, I meant the "Display Italic Angle" preference. If you have that enabled, it affects the sidebearings as James explains. And, yes, it doesn't matter. It just makes it easier to space italics by pretending that the sidebearings are slanted.
  • @Mark Simonson
    Oh! Totally understand it now. Yes indeed, I do have the Display Italic Angle preference checked. I gave it a quick check/uncheck and saw the difference between spacing. Glad to know nothing is wrong and I can keep pushing forward! Thanks so much for the help and guidance guys, means a lot.
Sign In or Register to comment.