Robofab Install on Mac 10.12.4

FL 5.1.5 build 5714 and OS 10.12.4: Robofab scripts won't work anymore despite reinstalling everything. There are different error messages either saying robofab.objects doesn't work or dialogs_fontlab_legacy2 can't be imported. Anyone have any idea?

Comments

  • Did you get the latest RoboFab revision from GitHub?

    You can also report problems there.
  • Yes, I upgraded everything and did the install for Robofab twice.
  • AppKit doesn't appear to be in the right location. Where does it go?
  • A full RoboFab installation consists usually of four components: RoboFab itself, FontTools, DialogKit and Vanilla. I’m not sure it requires AppKit.

    Here is a video by Ben Kiel explaining how to install those components.
  • Jens KutilekJens Kutilek Posts: 101
    edited June 28
    AppKit is used for Vanilla UI elements. It is part of PyObjC and installed on macOS by default. If it is not in the right location, your system may have been seriously messed up.

    I have seen easy_install and homebrew mess up systems really bad. If this is the case, you probably need to clean out all the Python stuff on your system and start fresh.
  • Reinstalled Python twice now, took out errant AppKit things, followed Kiel's video (again), reinstalled FontTools, DialogKit, Vanilla, result is the same:

    Traceback (most recent call last):
      File "<string>", line 10, in <module>
    File "/Applications/FontThings/robofab-master/Lib/robofab/world.py", line 95, in <module>
        from robofab.objects.objectsFL import CurrentFont, CurrentGlyph, RFont, RGlyph, OpenFont, NewFont, AllFonts
      File "/Applications/FontThings/robofab-master/Lib/robofab/objects/objectsFL.py", line 6, in <module>
        from robofab.objects.objectsBase import BaseFont, BaseGlyph, BaseContour, BaseSegment,\
      File "/Applications/FontThings/robofab-master/Lib/robofab/objects/objectsBase.py", line 29, in <module>
        from fontTools.pens.areaPen import AreaPen
    ImportError: No module named areaPen

  • Ben KielBen Kiel Posts: 20
    Seems like your problem has shifted: now the question is where did you install fontTools from? I've not tracked this of late, but it's very possible that fontTools has shifted where it is now putting AreaPen, hence the error.
  • Georg SeifertGeorg Seifert Posts: 457
    One thing I would not do is installing my own Python. That messed up my setup quite a bit the last time I tried. 
  • Ben KielBen Kiel Posts: 20
    One thing I would not do is installing my own Python. That messed up my setup quite a bit the last time I tried. 
    This. Installing a new python on OS X is a road to heartache/burn. (Installing Python 3 excepted here, until that's a standard OS X install —forgive me if it now is...)
  • The fonttools-master install didn't remove the old .pth file so that seems to work. But now it hangs here:

    Traceback (most recent call last):
      File "<string>", line 36, in <module>
      File "/Applications/FontThings/robofab-master/Lib/robofab/interface/all/dialogs_default.py", line 33, in AskString
        raise NotImplementedError
    NotImplementedError


    Is it safe to uninstall Python since Time Machine won't let me restore an older version?

  • This is the code the above Traceback refers to:

    def AskString(message, value='', title='RoboFab'):
        raise NotImplementedError

    def AskYesNoCancel(message, title='RoboFab', default=0):
        raise NotImplementedError

  • On a positive note: your RoboFab installation finally appears to be installed correctly now. :)

    However, the built-in FL dialogs are causing problems. That could actually be related to what version (and build) of FontLab you are running.

    Personally I am using FL 5.1.5 (build 5680) and that one works on El Capitan.
  • george_thompsongeorge_thompson Posts: 19
    edited June 29
    Removed Python 2.7.12, installed 2.7.10. Reinstalled robofab, dialogkit, fonttools, and vanilla. Same results. Vanilla and fonttools required pip to install so I'm wondering if I should try that to install robofab?

    FL is 5.1.5, build 5714, on Sierra.
  • @george_thompson As I mentioned in my previous post – your installation of Python, RoboFab, Vanilla, DialogKit and FontTools appeared to be correct. :/

    I recommend to try different builds of FontLab (such as 5680) because that seems to be the problem now.
  • Jens KutilekJens Kutilek Posts: 101
    Build 5714 should work.

    Regarding your Python installations, try to remove the folder ‘Python.framework’ in /Library/Frameworks/, that should revert everything to using Apple’s preinstalled Python. But proceed at your own risk ...
  • Removing Frameworks didn't work, tried to reinstall Sierra and that failed several times. Error message is now that FL can't find robofab.world which makes no sense. Maybe something is trying to tell me to give up making fonts (ironic joke).
  • Regressed to Python 2.7.6, earlier Robofab (2013) and FL 5.1.2 via Time Machine which should put me back in a working environment. The error message:

    can't import dialogs_fontlab_legacy2
    Traceback (most recent call last):
      File "<string>", line 36, in <module>
      File "/Applications/RoboFab/RoboFab/Lib/robofab/interface/all/dialogs_default.py", line 33, in AskString
        raise NotImplementedError
    NotImplementedError

    Interestingly robofab installer puts robofab.pth in "Fremeworks/Python" but FL looks in "Lib/Python" for it.
  • Some scripts are evidently too old, and won't run in Sierra. 
Sign In or Register to comment.